10 Mar, 2007, Guest wrote in the 1st comment:
Votes: 0
So. I find myself in a somewhat bad spot. It would seem that on my nice new 64bit OS and 64bit CPUs, gcc/g++ is defaulting to linking from 32bit libraries.(!)

This is causing some problems which I can't find any information on how to solve. So I'm hoping someone here knows how to fix this so that others who may eventually upgrade the way I have will be able to as well.

The compiler initially complained to me that the SQL library was incompatible with the 64 bit system. So I had to explicitly tell my Makefile to use the /usr/lib64 directory to get it. That solved the problem. But other users were finding other problems. Like Mindcloud appeared to be grabbing the 32bit pthread library which caused untold problems. The user since switched to explicitly calling on the lib64 pthreads and problems have been confined to oddball math errors showing up on the root console of all places.

So what I need to know is how do I force gcc to link only from the 64 bit libraries so that anyone who compiles is automatically using them? Or is this a problem with Fedora Core 6 itself and should I consider installing FC5 or some other distro that doesn't have this problem? ( Don't suggest Debian btw, too many problems of its own ).
11 Mar, 2007, Omega wrote in the 2nd comment:
Votes: 0
I'm going to recommend debian, sure it has problems, but hey, atleast you know going into the battle that there will be issues ;)

in all seriousness, there is a way to configure the linker to grab from the lib64, and with FC7 on its way, i'd just hold off and see what untold fixes it has.

because frankly, back-tracking to fc5 may not necessarily be the best thing with your amd64 duo core. It may handle things worse off then the fc6 does.

just my opinion.

Yours truly..
The Non Shit Flinging Monkey
11 Mar, 2007, Conner wrote in the 3rd comment:
Votes: 0
Why not just remove/rename the 32-bit library directory and replace it with a symlink back to the 64-bit library directory?
11 Mar, 2007, Guest wrote in the 4th comment:
Votes: 0
Davion tried that and it led to a pretty bad result. So that's not an option, especially in a production environment. There's got to be some way to force the compiler's hand.
11 Mar, 2007, Conner wrote in the 5th comment:
Votes: 0
Hmm, I only suggested it because I had to do something like that when I upgraded my GCC to version 4 (stupid apt upgrades..) and it worked for me, but I haven't had the pleasure of dealing with the whole 64-bit upgrade at all yet, so far my only 64 bit machine (single core cpu) is running windows and only bring used for some light browsing, trillian, and games. *shrug*