04 May, 2010, sweatsack wrote in the 1st comment:
Votes: 0
I'm trying to get AFKmud going on a VMWare virtual machine running ArchLinux. I got the newest version (214), unpacked it, recompiled the source (I don't know if this is necessary but it seemed like a good idea) and then ran ./startup

I get the following error:

'nknown option: '-
usage: csh [ -bcdefilmnqstvVxX ] [ argument . . . ].

I've googled this problem and have found no satisfactory answer; I was hoping you guys could help me.

Maybe another hint…I just installed VMware and ArchLinux today. I installed it specifically for this purpose; I just want to be able to tinker while I'm rustling up some hosting and while I'm at school (where they block the telnet & ssh ports). I didn't realize how "stripped down" it was and spent a lot of time installing software by trial and error. This is OK but I've hit a lot of snags because I forgot to install this or that…could that be a problem? On the other hand everything should be the latest and greatest version because I used pacman to grab it all just this afternoon.


Edit: also, some other things I tried…copying the startup file from 213, rewriting the code parts of the startup file by hand (this produced other errors, but I'm not sure if this is because I fixed the error I'm asking about, or if I just created more errors "before" it), changing /bin/csh to /usr/bin/csh, /bin/tcsh, etc.
05 May, 2010, Tyche wrote in the 2nd comment:
Votes: 0
The problem is the very first line of your startup script.
But since you didn't post it, we cannot give an answer.
05 May, 2010, sweatsack wrote in the 3rd comment:
Votes: 0
Very first line is:

#! /bin/csh -f

I assumed this was implied when I mentioned that this was a first install of AFKmud 214 and that I had also copied the stock startup script directly out of the 213 tar. My bad.
05 May, 2010, Tyche wrote in the 4th comment:
Votes: 0
Try removing the -f option


try running the bash script instead of the c-shell script
It's called ./startup.sh
05 May, 2010, David Haley wrote in the 5th comment:
Votes: 0
Also, make sure you have tcsh, not just the normal csh.
07 May, 2010, Sillviant wrote in the 6th comment:
Votes: 0
Actually there is nothing wrong with the -f flag. Just need to make sure you have tcsh installed and you won't have to mess with your startup script. The f flag just causes it to ignore any startup files for the csh shell. Which is useful for when your just wanting to use the c shell only for running a script, not as your default shell.