01 Jan, 2011, RoFAdmin wrote in the 1st comment:
Votes: 0
Hey folks,

ive been plucking away all day so far trying to get lua to work in ROM on cygwin.

Having a couple of issues, hoping someone might be able to point me in the right direction.

Got the lua source did a make mingw (as suggested on their site for cygwin).
then installed.

ROM source hated this.

Tried make linux, installed. ROM compiling hated this

tried make generic, installed. ROM does ok for most of the time while compiling till it gets to the end and tries linking stuff and i get
undefined reference to all the lua_ and luaL calls im making…..

Im guessing this is to do with the installation of lua, and not ROM of the compiling itself, but who knows, not i thats for sure.

Has anyone else installed lua on cygwin and got itworking properly in ROM or another base?


and before anyone asks. Yes i did try installing lua interpretor from the cygwin installain program. Still no go….
01 Jan, 2011, Tyche wrote in the 2nd comment:
Votes: 0
You just install it from the Cygwin setup program.
And definitely don't use MinGW compilation of library in conjunction with Cygwin as it calls microsoft VC runtime in an incompatible way.
Add -llua to your link params in your make file.
Other than the general observation that it does indeed work just fine using Cygwin, you don't provide enough information about your problem.
01 Jan, 2011, RoFAdmin wrote in the 3rd comment:
Votes: 0
Thank you tyche, problem solved. missing the -llua flag.